service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
no vpdn logging
vpdn−group pppoe
request−dialin
protocol pppoe
!
!
ip subnet−zero
!
ip dhcp excluded−address
ip dhcp pool
network
default−router
dns−server
!
interface ethernet0
no shut
ip address
ip tcp adjust−mss 1452
!−−− If the ip tcp adjust−mss 1452 command is not supported, try the
!−−− following configuration statement:
!−−− ip adjust−mss 1452
!−−− If this command is not supported in your current Cisco DSL Router software
!−−− release, either upgrade to the latest Cisco DSL Router software or follow the
!−−− procedure in Possible Required Configuration Steps on the PC.
ip nat inside
no ip directed−broadcast
!
interface atm0
no shut
no ip address
bundle−enable
dsl operating−mode auto
!
interface atm0.1 point−to−point
no ip address
no ip directed−broadcast
no atm ilmi−keepalive
pvc
pppoe−client dial−pool−number 1
!−−− Common PVC values supported by ISPs are 0/35 or 8/35.
!−−− Confirm your PVC values with your ISP.
!
!
interface dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname
ppp chap password
ppp pap sent−username
!
ip nat inside source list 1 interface dialer1 overload
!−−− If you have a pool (a range) of public IP addresses provided
!−−− by your ISP, you can use a NAT Pool. Replace
!−−− ip nat inside source list 1 interface dialer1 overload
!−−− with the following two configuration statements:
!−−− ip nat inside source list 1 pool
!−−− ip nat pool
!−−−
!−−− If Internet users require access to an internal server, you can
!−−− add the following static NAT configuration statement:
!−−− ip nat inside source static tcp
!−−−
!−−− Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used
!−−− for this example. You can open other TCP or UDP ports, if needed.
!
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1
access−list 1 permit
!−−− In this configuration, access−list 1 defines a standard access list
!−−− permitting the addresses that NAT will translate. For example, if
!−−− your private IP network was 10.10.10.0, configuring
!−−− access−list 1 permit 10.10.10.0 0.0.0.255 would allow NAT to translate
!−−− packets with source addresses between 10.10.10.0 and 10.10.10.255.
!
end
No comments:
Post a Comment